Taurus Car Club of America : Ford Taurus Forum banner

1 - 14 of 14 Posts

·
Premium Member
Joined
·
15,922 Posts
Discussion Starter #1
It should work. I saw a G2 Sable on eBay with a Windstar cluster (which the seller didn't list in the description) and it looked like it was a stock swap. I think you need to adjust the needles for the Temp/Fuel and maybe the tach needle isn't seated all the way. You could go get a Sable cluster and use the speedo.
 

·
Premium Member
Joined
·
17,415 Posts

·
Premium Member
Joined
·
15,922 Posts
Discussion Starter #3

·
Registered
Joined
·
3,034 Posts
It looks like the one in the bottom-most picture. It even has nearly the same amount of miles (just 3K more). I painted over that ugly grey with a platinum color and it looks sharp.

For now, I took the 120 mph spedo and put it in my old cluster and installed it into the car. It seems to be working fairly well (the needle kinda moves around a lot).

The car's plug goes right into the back of the cluster fine (both sides) but the wire that leads to the tachometer goes to a plug that
doesnt exist on my connector. Sorry if the terms arnt correct, but hopefully you understand what I'm saying.

To top this off, I just found out that the Napa store gave me the wrong price for my CV axel but I did find one for $59.95 at O'Rileys.
On the plus side, I got a temp. job with my uncle today, working at his shop. My first job was to get a 1996 Ford F350 running, and I did after replacing the injector control module (over $650 from Ford).
 

·
Registered
Joined
·
3,034 Posts
oops actually I see another diffrence in my cluster, it doesnt say "N O R M A L" on the temp gauge. However it does start at 0 mph instead of 10 mph like the top one. Sorry this damned server wont let me see all of the pics or messages at one time. POS (company computer) Its also as slow as a rock.
 

·
Premium Member
Joined
·
15,922 Posts
Discussion Starter #7
No, the picture doesn't cover up the text, but it resized!

The Fuel/Temp part has the "Fuel Door" pointed to the wrong side so it'd look odd. Try yanking a cluster from a Sable. It'd surely fit.
 

·
Registered
Joined
·
3,034 Posts
Well I can possibly get a cluster from my cousins freinds 1995 Sable (wrecked). I'm going to call and see.

Gee, wish I'd known this before spending $50 on a cluster that wont work. Whoever said a Windstar cluster is a direct swap for a Taurus one needs to think again. The speedometer head unit is the same and it looks similar but its definatly not a bolt-in replacement. I'm not trying to blame someone really, just venting fustration. I dont exactly have a lot of money and this was a birthday present to myself (since other wise I wouldnt get one LOL).
 

·
Premium Member
Joined
·
15,922 Posts
Discussion Starter #9
The Windstar speedo should have worked. I did see a G2 Sable on eBay being sold with one. And I've seen pics of a couple of members having one.
 

·
Registered
Joined
·
3,034 Posts
The speedometer from the Windstar cluster DOES work in my old cluster, but the cluster itself from the Windstar wont because its too big and its wired totally diffrent.

Evedently someone took just the speedometer head unit out of a Windstar cluster and put it into the stock Sable cluster (w/ tachometer already in it).

Right now I have my stock, no-tachometer cluster in my car but I put in the 120 mph speedometer in place of my old 85 mph one.
 

·
Registered
Joined
·
933 Posts
there are many different kinds of clusters. some of those old windstars have the all digital cluster, like some Sables and the older higher end Tauruses. maybe those are plug and play? chances are you would need to find the right windstar cluster to match what equipment your car has.
 

·
Registered
Joined
·
350 Posts
John, not that this is much consilation, but the Windstar cluster does not work in the Taurus. We have a windstar and have had many Taurii. When my father wanted to swap his cluster in the Windstar he took one of my SHO clusters only to discover the same problems.
 

·
Registered
Joined
·
3,034 Posts
Thanks for being honest Mikey. I was beginning to thing it was just me going bonkers (known to happen from time to time). My next step is to try to secure a cluster from a 92-5 Sable and put the 120 mph spedo in it. At least my "FUEL DOOR -->" will be pointing the right way, LMAO!

I'll let you guys know.
 
1 - 14 of 14 Posts
Top