Taurus Car Club of America : Ford Taurus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
When accelerating, there seems to be a bit of difficulty in accelerating around 25mph and even up 'til 30-35mph or so. It will spike to 2-3k RPM but still takes awhile to get up in speed. However, when at a constant speed, its back to 1.5-2k.

Once I get up, especially around 45mph, accelerating is a whole lot easier.

I haven't driven for that long lately that the engine would be warmed up the whole time. I'll try to see if that makes a difference or not.

A SES code was thrown. One of the O2 sensors was reportedly malfunctioning. Could this be the issue?

I'm not a vehicular genius, so I may be overreacting or something, but I'm learning to take care of my ride.

Thanks!
 

·
Registered
Joined
·
126 Posts
My duratec does the same, but after adding a nice Lucas Additive, my engine started to pick up speed alot nicer and faster afterwards.
 

·
Premium Member
Joined
·
1,699 Posts
When accelerating, there seems to be a bit of difficulty in accelerating around 25mph and even up 'til 30-35mph or so. It will spike to 2-3k RPM but still takes awhile to get up in speed. However, when at a constant speed, its back to 1.5-2k.

Once I get up, especially around 45mph, accelerating is a whole lot easier.

I haven't driven for that long lately that the engine would be warmed up the whole time. I'll try to see if that makes a difference or not.

A SES code was thrown. One of the O2 sensors was reportedly malfunctioning. Could this be the issue?

I'm not a vehicular genius, so I may be overreacting or something, but I'm learning to take care of my ride.

Thanks!
[/b]
Allow me to introduce you to: Mad Vulcan POWAH

Your torque and HP peaks are 2000 rpms apart. Vulcans are great for cruising, not so much for acceleration.
 

·
Registered
Joined
·
2,492 Posts
IMHO, sounds like your TC is slipping.

How many miles?

You might be due for another TC :makeadeal:
 

·
Registered
Joined
·
52 Posts
Discussion Starter #6
235k+. I don't have logs for anything after '04, IIRC. Only had this one a few months now...

I must add, though, that it seems the extreme cold we've been having the past few days has had an impact; after warming up, it didn't do it to the same extent...

I don't remember which code it was and stupidly didn't have it written down. Probably something to look into further, though my brother and uncle tried to convince me it wasn't all that necessary.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #7
First of all, its been slipping, too. I just noticed that.

Second, this activity is still occurring even when the engine is in the middle of the engine temp gauge (not sure what the technical term would be).

When I had a couple leaks repaired, they claimed to put in 6 bottles (quarts, right?) of trans fluid. Upon my brother's request, I put in another 7 of Valvoline Mercon V trans fluid.

Could this be because there was actually more than 6qts in there when I added another 7? Or did they put in the wrong kind?
 

·
Premium Member
Joined
·
15,922 Posts
The total capacity of the trans is 12 to 14 quarts. If you were able to put 7 quarts in without it spilling out the vent hole then you were extremely low on trans fluid.
 

·
Registered
Joined
·
1,771 Posts
My duratec does the same, but after adding a nice Lucas Additive, my engine started to pick up speed alot nicer and faster afterwards.
[/b]

Which additive? Trans, engine, power steering?
 
1 - 9 of 9 Posts
Top