Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
75:25 H20:4%Wht Vinegar Radiator Flush feasible? Forced to run 4th gen V6 ohv 4 weeks on city water only. About to change out hoses and water pump. White deposits on upper radiator hose fitting. This city has super hard water! Planning to run it <10 min.
 

·
Super Moderator
Joined
·
7,688 Posts
That will dilute the acetic acid to 1% and 99% water. I doubt that will do anything.

Why not use a heavy duty commercial radiator flush available at any parts store for a few $$. Be sure to follow the label directions.

Every water cooled engine on the planet more than a year or 2 old has a little of the "white residue" here and there and it causes zero problems.
 

·
Registered
Joined
·
6,576 Posts
Agree on commercial flush! They contain a type of chemical that will attack deposits and rust but not eat the good metal. It will also treat the clean surface to neutralize from any future corrosion. Peak brand I used and had a Chemist at my company I retired from look at it. Same chemical to clean huge 15 story boilers in the electrical generation industry worth hundreds of millions of dollars.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Thank you for responding!! No access to Club since joining. (No tech email to respond, phone, etc. Address at end of this post.)No leaks until I changed fluid in May. Color good. Added Prestone flush. Drove 30 miles. It was towed next day.(not 4 repairs) 2Leaks on return. tiny from beside petcock. Larger (now know) from H20 pump. Driven on water only since. Short trips of 2/3 mi. Wondered if that flush took out more than should have? 2002 ohv Bull V6 182ci 3L. How will I do any flush with a gushing/damaged water pump? But if 5 min is better than 0 min, I'll get on bus n get the chems at Wmart! Don't want rust in hoses/engine/radiator etc.going through new pump!
Reservoir has many chambers will not come clean.Tight budget. Stella has been running on water for awhile and flush in May showed in good shape. Any suggestions? Motor mounts bad (big job for mature lady!)Think mounts may have damaged pump. Waiting on those, tensioner, belt, thermostat, etc. Local too $$ Hoses look ok. Replace? Thermostat working. Replace? After learning how bad mounts damage components, won't drive her at all. Tmrw my bday! Thinking heater hose backflushing w/H20, then chemical without running car.
I'm thrilled to be on here at last! Shed tears of frustration since March, Stella's going down fast. Neighbors/shade trees all tell me things I don't trust. This site's the BEST! I opened in incognito (mistake-didn't even know it was there) and whamoo! get to reply! Happy BDay to me! Want to learn all I can. Love fixing my car.
 

·
Registered
Joined
·
128 Posts
We are glad you like fixing your car, from reading your post, it looks like you have plenty to do! Also, its a little hard to follow along with what you all said ^ above, it sounds like a water pump 1st thing. Also, in my 40 plus years of driving, and diy, i have never heard of engine mounts damaging anything, unless they are both broke and your motor is only held in there by the transaxle, and gravity. Backflushing vulcans is done all the time for the heater core. How many miles on car? Good luck, and Happy Birthday!
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
4 Participants
Triton3.5
Taurus Car Club of America : Ford Taurus Forum
A forum community dedicated to the Ford Taurus and SHO models, Mercury Sable and Lincoln MKS. Join the discussions on EcoBoost, aftermarket performance, and more!
Full Forum Listing
Top