Taurus Car Club of America : Ford Taurus Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 · (Edited)
lately on my 99 i have been noticing it has a very low idle rpm of around 500. yesterday when i started it up i went to pull out of my spot going up a hill and it stalled on me. there is a service engine light on but i was wondering if this is an easy fix or is it going to cost a lot?

EDIT:just went out and noticed a small wet spot. almost positive its trans fluid because i checked it and its low. is this a possible cause. whats funny is that as i was doing this the engine kicked back to life and was idling at around 1k like regular. light went off too.

EDIT EDIT: i also checked my mpg for the last 100 miles today. about 16mpg. i do have subs in the back but theyre no more than 50 pounds.
 

·
Super Moderator
Joined
·
8,659 Posts
Idle: Clean or replace the IAC.

If CEL is on, get the code or codes read.

Leak could also be PS fluid. Locate the source of the leak.

Heavy right foot, lots of idling, kills gas mileage. With that said, 100 miles of driving is not nearly enough miles to get an accurate MPG number.
 

·
Registered
Joined
·
670 Posts
If it does still persist cleaning the Idle Air Control valve with brake cleaner won't hurt and reading the codes as stated previously.

16 MPG isn't that crazy as thats what i get in my 3.0 vulcan with about that much or more weight in the trunk. My city mileage sucks with a/c always on and high idle time cooling off the car.

If i fill up and go straight highway with cruise on i top just over 30 MPG.
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #4 ·
okay thanks guys i think the IAC is what it is. i got p1507 IAC speed error and p1504 IAC fault. how much is one, and where is it under the hood.
 
1 - 6 of 6 Posts
Top