Taurus Car Club of America : Ford Taurus Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
587 Posts
here is what it sounds like to me. your egr is stuck closed giving a too lean on bank 2 and egr insufficient flow. here is a way to test the egr get a mr vacuum . vacuum pump there like 30-40 bucks mite even be able to rent one. attach it to the egr vacuum line instead of the car vacuum line plug the cars vacuum line. apply vacuum and see if the car stalls out if it does not stall or stumble the egr is the fault. more then likely plugged shut.this is if you got 30 inches of mercury or full vacuum. at that point it does not stall replace the egr or try to clean it with carb cleaner if no luck doing that replace it. it also maybe the egr vacuum solenoid but sounds more like egr. so if fixing the egr fails or vacuum applied works try the vacuum solenoid. hope this helps good luck on it
 

·
Registered
Joined
·
587 Posts
UPDATE: After close examination of the EGR Vacuum Solenoid (not the actual EGR valve--the piece on the other side of the engine), I found one of the plastic nipples that one of the vacuum lines connects to had a crack in it. A little superglue and a small piece of heat shrink tubing and viola! 24 hours and 50 miles later...no more code. Keeping my fingers crossed.

good to hear hope you found the problem. i am keeping my fingers crossed too.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top