Taurus Car Club of America : Ford Taurus Forum banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
1,219 Posts
Discussion Starter · #1 ·
So... For some reason.. recently my car seems like it's running a little bit harder, and working a little harder to keep up at normal engine speeds. It just feels a little bit rough.. or something. I popped the hood and listened. It sounds like a little bit of a rattle goin on.. on the passenger side. Oh! btw.. '95 taurus GL, 3.0L.. anyways.. what could this be? I checked the oil and it's a little low and a little darker than it should be. I just changed it June 2nd..
We had some pretty heavy rain recently and I had to drive through some water to avoid another car.. It was kinda deep, it reached the bottom of my car at least, maybe a little higher. But... the water level wasn't as high as my tail pipe.. so... I don't think it was that.. I was only in it for like.. 20-30 feet..
Help..
 

·
Registered
Joined
·
679 Posts
<_< ****************You don't mention miles on odometer.
This could have nothing to do with the water. If high miles, one rare possibility is that the catalytic converter is worn or wearing out. One one Ford vehicle I had, I must have replaced every part the mechanic had in stock from spark plugs to spark plug wires, rotor, etc. Later, I found out that the converter was clogged. Worn out but no holes in it. The inside had deteriorated. Made vehicle run slow and sometimes rough. Just a thought.
 
Joined
·
14 Posts
sounds like a little bit of a rattle goin on.. on the passenger side
I have a '95 Taurus GL, and when I got it something was rattling under the hood. My dad took a look at it, and it turned out to be a heat shield. Don't know if there's anything permanent you can do to stop it...provided that is the problem, but I messed with mine and it stopped for a few weeks...And I don't think a heat shield would cause any proformance problems...if worn or dirty, try replacing filters, plugs, wires, dist. cap etc, etc. My brother's car worked better after he tuned his up :lol2:
 

·
Premium Member
Joined
·
1,288 Posts
Yeah, my car had a defective catalytic at about 10,000 miles. But the mileage went into the toliet and the power was Honda Hampster style. It'll also throw an engine code though if it is the cat. Try some fuel injector cleaner. I know mine was having power trouble and I put some into a full tank. Worked great. I actually run a bottle about every month what with the crappy California gas.

-mobiuslogic
 
1 - 4 of 4 Posts
Top