Taurus Car Club of America : Ford Taurus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,552 Posts
Discussion Starter #1
ok, not a good start for the new yr.

I put my hazard light briefly in the morning... then i switch it off...

then the turn indicators dont work... I tap the hazard light push switch lightly... then left indicator alone will work... then after fiddling around with the hazard light s/w i got the indicators to work.

any idea what could be wrong? this 96 GL gen 3
 

·
Premium Member
Joined
·
8,433 Posts
A friend of mine had the same problem. We took it apart and it was full of tar and nicotine
. He was a heavy smoker.

Cleaned it out and everything was OK
 

·
Registered
Joined
·
1,552 Posts
Discussion Starter #3
what did you take apart exactly..

remove the top & botton cover on the steering wheel column.. and then...
??
spray WD 40
 

·
Registered
Joined
·
313 Posts
This is your multifunction switch gone bad. Don't bother replacing the relay. I did and it didn't work.

The bad news is it lists for $85.00. The good news is you can but it from Ford Parts Network for $69.00 --- Although with shipping it probably is $85.00 --- So you might as well get it from the stealership.


More bad news is that you need to replace it. I haven't heard of a fix working (like WD40 or anything.
 

·
Registered
Joined
·
1,552 Posts
Discussion Starter #5
oh god!

I thgt the MF switch is only for the wiper & washer.. and sits in that stick...

anyways.. the problem seems to be based on the seating of the hazard light push down switch...
 

·
Registered
Joined
·
313 Posts
It's all interconnected. I could turn on my hazards and then signal left or right and get all kinds of wonky things going on with my lights. I also had the very occasional odd intermittent wiper issue going on. After replacing the switch everything was fine, from the wipers to the turn signals.

If it's minor & you can live with it, then fine. Here in VA your car wouldn't pass inspection, so you would have to change it.

I seem to remember some posts about cleaning the MFS in the archives. I think they were related mostly to the wipers, but it's all the same thing.
 

·
Registered
Joined
·
25 Posts
My mechanic did the multifunction in 32 minutes. My problem was...hit turn signal
and the wipers would occasionally operate, no problem now.
 

·
Registered
Joined
·
313 Posts
MFS is not a hard thing to do. It's mostly about being patient. Took me about 15 mins or so. Most of the time was figuring out what to unscrew.

You may want to check http://www.rockauto.com/ I saw it there for about $45.oo but I don't know if the switch is OEM or not.
 
1 - 9 of 9 Posts
Top