Taurus Car Club of America : Ford Taurus Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter · #1 ·
I have a 2005 Ford Taurus. It has been good to me, and now has started having some problems.

It has 150,000 Miles, and just a few thousand miles ago, the Transmission started acting Weird.

When I start the car, and drive it cold, it is perfectly fine. However, after it warms up, it will start shifting poorly.

When its warm, and I come to a stop, the transmission feels like its trying to downshift really hard, even when I'm stopped. When I try to drive away, it feels like its jumping in and out of gear until I finally get going over about 5mph, Then it shifts like it should, and drives fine, until I stop again.

This only happens when its warm. I have plenty of fluid in there. I have never flushed it. I bought the car at 75,000 and the fluid seemed new when I bought it. The fluid is not gritty, but is a very dark brown, borderline black.

I read some stuff about the trans position sensor and shift sensors being contained in the same module, but could not find any info for my model of car.

Can anyone help me with this?
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #3 ·
TRS Meaning? Trans Range selector? I'm trying to figure this out, and praying that my clutches aren't just gone. I really can't afford a new trans, and don't have the time to put one in.
 

·
Registered
Joined
·
3,377 Posts
yeah... trans range sensor. a misalignment can cause it to act like its bad also. if there is alot of play in the linkages it might not be in the seat fully
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #5 ·
And is that located right on top of the trans? I see that the connector for the Trans is right there, and there is some linkage on top as well. Would the sensor be right under there?
 

·
Registered
Joined
·
3,377 Posts
it might take maybe a day or so for the thread to get goin. there are a couple of trans guys that are on here that should show up. have you pulled any codes?
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #9 ·
I have a Scanner that I got from my Matco Guy, but I don't see any Trans codes. The only codes I have seen are from random misfires, but I'm guessing thats from how bad the car is jerking sometimes. The Knock Sensors must be thinking I'm misfiring.
 

·
Premium Member
Joined
·
2,543 Posts
Changing trans oil and filter now will probably make things worse.

You are fortunate to get so many miles out of a Taurus Trans. My 2000 and 2004 LXs both started having trans problems at about 30,000 miles each.
 

·
Registered
Joined
·
141 Posts
Discussion Starter · #12 ·
Just an update. The Trans went out completely while Driving the other day. Was on the freeway, when all of the sudden my RPM's shot up (was using cruise control) and My Trans was gone. No forward, no Reverse. I'm guessing its either the Pump, or the Torque Convertor.
 
1 - 12 of 12 Posts
Top