Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Premium Member
1992 taurus
Joined
·
532 Posts
Discussion Starter · #1 ·
hey everyone.
been awhile since I was on here last. the site looks awesome.B)

my trans just started this a week ago. It doesnt slip or atleast doesnt feel like it slipping. but it shifts in all gears up and everything works. but when in o/d it shifts into o/d but when i come to a complete stop, i loose all forward gears, but if i shift from revrse back to drive it kicks righ back in, and it doesnt do this at all when im in regular Drive and and 1st. Only in o/d it goes to nuetrel. I looked around and saw bout a retainer clip for o/d but saw it it looses o/d mine works. im not sure. any help would be great. its a 98 se vulcan with AX4N. no trans light or ses light on. thanks again for the help in advance.
 

·
Premium Member
1992 taurus
Joined
·
532 Posts
Discussion Starter · #2 ·
anyone have any ideas?? id really appreciate it any help. i really dont want to have to change the trans out if it doesnt need to be...
 

·
Registered
Joined
·
205 Posts
Check fluid levels? TRS on its way out? VSS too?
Most trans shops will do a free diag, and drive it on a computer to tell you what readings are off such as VSS and TRS voltages, Electronic shift solenoid, etc.. So Id get it checked out..
Edit: There are a lot of dishonest places out there, If the first guy suggests a total rebuild, say that you'll be back and go get a second opinion.
 
1 - 5 of 5 Posts
Top