Taurus Car Club of America : Ford Taurus Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
1999 Taurus SE wagon, 3.0 Duratech. Driving along the 417 in Ottawa at about 110 KMs (70mph) and the car gives an ever so slight hesitation. So slight the passenger doesn't even notice. A minute or so later and it happens again. This time I catch the tach, rpms drop from 2500 to 2100 and return. Now I start experimenting. Holding rpms at 2500 it hesitates more often (with rpm drop). Taking foot off gas rapidly at any speed drops the rpm instantly with a more than normal feel of deceleration. Driving around town at slower speeds, a couple glances at the tach showed it would intermittently freeze indication for a second or two with no noticable jerking or hesitation.
Anybody seen something similar? Any ideas?
 

·
Premium Member
Joined
·
15,578 Posts
I think we'd need a little more information regarding this, such as the mileage of the car, if the maintenance is kept up, etc. Have you checked the codes at an Autozone (do they have them in Canadia?)? Have you checked the throttle linkage cable???

JR
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
Milage is 143,000 KMs (85,000 Miles). Car is well maintained and in good mechanical shape. Have not had codes checked, I was unaware transmission had codes, thought they were only for engine emmission systems. We don't have Autozone here (that I'm aware of). Will have codes and linkage checked this week. Thanks for the info.
 
1 - 3 of 3 Posts
Top