Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
Searched a bit for an answer for this but didn't see one, so here goes.

About 2 weeks ago, my wife's 02 sable started what seems to be shifting back and forth from Drive to OD under hard acceleration.

Let me give you an example of the circumstances.

While pulling from a ramp onto the highway, you put your foot into the throttle. It will go through the lower gears normally, then going from either 3rd to D, or D to OD (I only experienced this once so I wasn't counting gear shifts) it will seem to try selecting the next gear, then kick back to the previous gear. The engine will be at ~3800 rpm, start dropping for the next gear, then kick back to 3800 rpm again for about 1/4 second, they try changing gears again.

It will do this repeatedly, until letting off the throttle, then shift right into the next gear.

It will then drive normally until being in the same situation again.

Anyone know what could be causing this? OD Solenoid?
 

·
Registered
Joined
·
671 Posts
Searched a bit for an answer for this but didn't see one, so here goes.

About 2 weeks ago, my wife's 02 sable started what seems to be shifting back and forth from Drive to OD under hard acceleration.

Let me give you an example of the circumstances.

While pulling from a ramp onto the highway, you put your foot into the throttle. It will go through the lower gears normally, then going from either 3rd to D, or D to OD (I only experienced this once so I wasn't counting gear shifts) it will seem to try selecting the next gear, then kick back to the previous gear. The engine will be at ~3800 rpm, start dropping for the next gear, then kick back to 3800 rpm again for about 1/4 second, they try changing gears again.

It will do this repeatedly, until letting off the throttle, then shift right into the next gear.

It will then drive normally until being in the same situation again.

Anyone know what could be causing this? OD Solenoid?
Could be throttle position sensor
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Ok thanks...

I took a look at the tranny fluid, and it seemed a little thick and stinky.. It was still red, and it stunk, but it wasn't a burnt smell.

Turns out this is original fluid with 100k miles on it, so I siphoned out a gallon and replaced it with a gallon of fresh fluid. I will do that a few times to add detergent back into the mix before doing a complete fluid change. This worked well on the explorer I bought with 110k miles on original fluid for getting rid of shudder while shifting.. Now it's at ~130k and still kicking.

If that doesn't help, then I'll look at the TPS..
 

·
Super Moderator
Joined
·
8,586 Posts
I would drop the pan and change the filter also.
 
1 - 6 of 6 Posts
Top