Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
7,306 Posts
Discussion Starter #1
Well the Taurus has been having very hard cold starts lately ... but if I poor man prime it, the car starts right up. I'm thinking this might be a fuel injector or something in the fuel system.

So I went to buy some of that fuel injector cleaner (aka funky smelling stuff that does nothing) the other day.

I misread the bottle and put in enough for 32 gallons - I only have an 18 gallon tank and it was full at the time. I realzized I put too much in when I thought it was strange that I would need TWO bottles to cover 20 gallons ... bottle said 1 for 16 gallons, not 1 for 10

Other than increased fuel consumption (already burnt 1/4 tank going 50 miles), can this do any other damage?
 

·
Registered
Joined
·
179 Posts
Most bottles will say something like, "enough to treat up to 18 gallons." You can use it to treat less. Two bottles is nothing to worry about.

If it keeps you up at night, top off your tank each time you drop 1/8 gallon 3 times. You'll have the concentration down in no time.
 

·
Premium Member
Joined
·
7,306 Posts
Discussion Starter #5
It's nothing to worry about. But as for the hard starting, have you checked the fuel pressure to see what it is? Or see if it bleeds off while sitting?
[/b]
Have not checked the fuel pressure but I expect its going somewhere because the priming helps.


Most bottles will say something like, "enough to treat up to 18 gallons." You can use it to treat less. Two bottles is nothing to worry about.

If it keeps you up at night, top off your tank each time you drop 1/8 gallon 3 times. You'll have the concentration down in no time.
[/b]
I usually fill up at 3/4 so I'll probably fill up next tiem I drive.
 
1 - 6 of 6 Posts
Top