Taurus Car Club of America : Ford Taurus Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
anybody have any insight as to what I'm looking at here? (specifically the hard aluminum looking bend)

thought I had a vacuum leak.. turns out I was correct. Forgot to plug a hose back in.. BUT the car still doesn't sound quite right.
Tire Automotive tire Helmet Automotive lighting Tints and shades
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
That elbow is actually plastic and is at the leading end of one of the heater hoses. On the end is a quick connect fitting for the metal tube that it connects to that leads to a rubber hose that in turn leads to the water pump housing. That elbow & fitting can be brittle after this many years, so be cautious when handling it.
Are we talking about the same part?
Hood Automotive lighting Automotive tire Car Vehicle
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Now that you've circled the part, no. Thought you were referring to the elbow above it. I have a '04 Sable with the same engine and just took a look. Nothing like that on mine. I've pulled engine parts from both years (Taurus & Sable) and they always looked the same. Only thing in that general area that has a metal-like appearance is an aluminum heat shielding wrap around a wiring harness that leads to a connector clipped to the top of the tranny...but, on mine there is no bend in it. The connector may lead to a rear O2 sensor...but, not sure.
Thanks for clarifying!
 
1 - 5 of 5 Posts
Top