Taurus Car Club of America : Ford Taurus Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I've got a 2003 Taurus Flex Fuel with 130K miles. Recently it began stalling when it warms up. It's been hot 90+ when this occurs. It'll run fine til it warms up ~10 mins of drive time then when I let off the gas and the RPM's drop it stalls. Won't start again til the key is cycled off/start. Stalls in P, N or any other gear as long as the RPM's drop to idle or coast condition. If I start it in N and keep the RPM's up then shift to drive, I can drive it as long as I don't try to stop or coast. No check engine, but there was a P0113 code. I've cleaned the IAC valve.

If it were a fuel delivery problem or an ignition problem, I'd expect it to stall when I'm on the gas as well. Possible problem with the IAC solenoid when it heat's up? Regarding the P0113 code, I believe this was caused by disconnecting the MAF sensor when it was running. Any help would be appreciated.
 

·
Registered
Joined
·
670 Posts
Are you plugs and wires stock? If so that could be the issue.

Time to change the fuel filter? Do it if you haven't anyway.

Try replacing the IAC valve; sometimes cleaning isn't enough.

Clean the MAF with MAF cleaner only if you haven't.

Air filter clogged maybe?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
replaced plugs, wires, 6 pack coil, fuel filter, cleaned MAF, throttle body. Still stalls when it gets warm.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Turned out to be a failing camshaft position sensor and resulting failure of the camshaft sychronizer. Also remedied the occasional stumble at hwy speeds.
 
1 - 4 of 4 Posts
Top