Taurus Car Club of America : Ford Taurus Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
833 Posts
Discussion Starter · #1 ·
Of course before leaving checked the fluids and tire pressure. Overpacked with clothes and food and the girlfriend. Had to stop in New Hampshire, tax free, to buy likka, beer, and tobacco. And then vacationland,


Can't make it to the island without the ferry or a boat. But the taurus wanted to come with us.



There, I fixed it. using rocks to hold the top on!! Classic.


My favorite seat on the island.



First dinner, Beer Can Chicken !!


Next night's dinner, mussels and lobster. The mussels we pick out of the tidepools ourselves, the lobstahs come fresh out of the traps from Covey right down the street.





So we were going to leave the island Sunday, but the Taurus' idle decided to go haywire. I thought the IAC was getting stuck open. I got out and whacked it and the idle went back to normal. So I'm out on an island, where the hell do I get car parts!!?? Happen to see the local AAA guy and he ordered one for me from Portland for less than 40 bucks!!! Only thing was I had to wait till Tuesday. Oh well!! Too bad after I got home it did it again!!! 2000 rpms in park!! Get out and whack the new IAC, goes back to normal, but.... oops. This time I notice the vibration from whacking it released the sticking throttle cable.
Removed that cover and find the cruise cable is disconnected and getting caught when the throttle is applied, raising the idle. Reattach and good to go. Out 40 bucks. Oh well, it woulda gone bad soon enough at 87000.
 

·
Registered
Joined
·
833 Posts
Discussion Starter · #2 · (Edited)
why the hell can't any pics be seen??!?!? never had a problem with the other software

ok, so this somehow posted twice and this one without pics, only pictures of whatever those are. this is stupid. i'm not a computer wiz, but i was able to use the other system before this retarded changeover and make pics go where they're supposed to
 
1 - 2 of 2 Posts
Top