Taurus Car Club of America : Ford Taurus Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter · #1 ·
My driver side tail light isn't working. A visual inspection of the bulb revealed this isn't the problem. I even tried swapping bulbs and it still didn't turn on. Is this related with the combination switch (a.k.a. multi-function switch) or is it a different problem?
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #4 ·
parking light, comes on just fine when i press the brakes. it actually turned on last night when i turned the parking lights on, seems to happen very intermittently. i did clean up the connections but they looked fine to begin with. anyone else ever had this problem?
 

·
Registered
Joined
·
619 Posts
Just splice in a new socket...terminals can get weak and not make contact, even though they appear clean.
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #7 ·
i think a connection inside the car might be to blame since it will light up after keeping the current running long enough. might replace a wire and/or connector(s).
 

·
Super Moderator
Joined
·
8,732 Posts
Your statement doesnt make sense..... when the bulb is not lit up, there is no current flowing to that filament in the bulb. Try this: turn lights on wnd wiggle the bulb in the socket and see if you can get it to light up by wiggling, replace the socket. Any parts store will have them.
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #9 ·
i'm using led bulbs in my tail lights. not sure if that makes a difference or not.
 
1 - 9 of 9 Posts
Top