Taurus Car Club of America : Ford Taurus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Is this common? As I have no history on the car from previous owners, I have to assume ot figure things out as I go along.

My hood is stuck, pulling the cable (broken latch) doesn't "pop" the hood, but it does seem to unlock it.

From there, I have to pry it up from the outside of the car, then it opens up. Hydraulics keep the hood open with no problem, so why doesn't it "pop" ...
where should I look first?

Thanks,
Drew
[email protected]
 

·
Registered
Joined
·
887 Posts
I had the exact problem when I had a 1998 Taurus. I also lubricated the latch with WD40 and it fixed the problem (at least for a few months at a time, at which point I just decided that was "routine maintenance")....

I have also had a similar problem with the trunk of my 2001 and I used a silicon (waxy) grease for high-end bicycle maintenance and that seems to last for a little less than a year at a time.....
 

·
Premium Member
Joined
·
9,959 Posts
seems to be a common problem. My hood did the exact same thing. I thought it was the struts at first but they work fine. I cleaned and sprayed the latch assembly with silicone and it works fine now.

Sometimes the trunk lock won't unlock with my key. If I jiggle it and play with it will sometimes work. Othertimes I just hit the remote trunk release and open it.
 
A

·
Guest
Joined
·
0 Posts
I have the same problem, I just assumed it happened when I took my hood struts out for my front STB....I'll have to try the WD-40.
 

·
Premium Member
Joined
·
2,415 Posts
If the wd-40 doesn't fix it, try raising up the hood stops a couple twists. This worked for me, just make sure you raise them slowly and incrementally because if you bring them up too high you'll bend your hood when you close it.
 

·
Registered
Joined
·
249 Posts
Mine seems to work well if one person hold the lever and another person hits it a little, heh. Hitting things always seems to work. Sometimes my dash will rattle where it's seperated (stupid Florida sun) and it stops that. My rear passanger window stuck one time and my friend hit it and it worked again, well.....temporarily, now it wont work at all, but hey it did that one time!
 

·
Registered
Joined
·
10 Posts
I have had the exact same problem with my '97 Sable GS. I use Slick50 lubricant, that's a general purpose lubricant in an orange can.

I have also used regular grease.
 
1 - 9 of 9 Posts
Top