Taurus Car Club of America : Ford Taurus Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Hi all

I replaced all for of my struts with Strutteks form ebay or prime choice auto parts. I replaced pretty much everything in the front end and I get a rattling/loose noise up front when going over bumps. I was able to reproduce it by pushing down on the fender. It is mostly the passengers side but the drivers side does it a tad. Has anyone heard of the strut mounts on new struts being bad and making noise? Should I buy another type of strut or should I just get a new strut mount? Do I need to replace the large nut on the top of the strut if I do it?

Thanks
 

·
Registered
Joined
·
95 Posts
It is likely the sway bar links. If so is an inexpensive fix. Links are about $40 each 1/2 hour work each side, use a cut off wheel to remove old links, as are likely too rusted to undo.
 

·
Registered
Joined
·
23,582 Posts
^ Hes already replaced them also, but should check if theyre loose or faulty. I replaced the oem white plastic ones with metal duralast from autozone (supposedly rebranded moogs) and within a year the pass. one was making a dribbling/pattering noise when going over bumps/uneven surfaces. Replaced with lifetime warr. Ive had numerous issues with the duracrap endlinks and outer tie rod ends.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
I can clearly hear the noise coming from the rubber on the strut mounts.

I removed the sway bar links to rule those out. Still the same noise.
 

·
Registered
Joined
·
95 Posts
I can clearly hear the noise coming from the rubber on the strut mounts.

I removed the sway bar links to rule those out. Still the same noise.
stupid question I know .... but needs to be asked. Are all bolts tight I can see a guy overlook tightening down those bolts under the hood, as you would have likely only finger tightened them, then went to work on securing the lower end of the strut
 

·
Registered
Joined
·
13 Posts
Struttek Primechoice ebay 2004 Taurus rattle

i have a 2004 ford taurus and i installed struttek prime choice struts from ebay on the car but not it rattles like something is loose its fine on smooth roads but any slight bump it starts to rattle really loud and also the steering wheel has a weird noise now like tick tick and i checked the cv axles they are fine the car never had this issue before even with blown shocks any ideas to what is causing this is it the sway arm end links ? they were not making any noise before why would they now ?
 

·
Registered
Joined
·
25 Posts
I just installed StrutTek struts in the rear and they work ok but over big bumps they kind of clunk but that could just be all the junk in my trunk. When I replace the front passenger side strut with one from the auto wrecker a rattling noise developed but I think it's just because the strut mounting plate in out of alignment. I can clearly see where the mounting plate was before by the difference in color and it's about one centimeter off.

I still have to put the front StrutTek struts in and I'll realign the mounting plate at that time and I'll let you know if that fixes it.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top