Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Hi everyone!

I have a 2011 Taurus SEL that has developed a strange radio problem. The radio will not respond to any of the buttons when I start the car, then after about 2 - 3 minutes, the buttons will start working and the volume knob will also start responding. Then after about another 5 minutes, the radio display will start changing and "Set Time" will popup. Then it will switch to "Load CD", (I've never used the CD player in this car). Then the radio will just shut off and randomly start again.

I've tried deleting my phone from the Bluetooth menu and disconnecting the battery for about 20 minutes with no results.

Just to mention that my Taurus is the first gen, (manufactured in Sept 2010), so it doesn't have a backup camera setup and display, just the radio.

Any suggestions?

Thanks!

zog
 

·
Registered
Joined
·
132 Posts
This vehicle line seems to have MORE than its share of problems. I'm seriously thinking of selling my Taurus. If & when I do, will never , I mean never go Ford again. Even the Dealership I bought mine new from was BAD, very BAD.
 

·
Registered
2013 Limited
Joined
·
469 Posts
Check your battery, voltage and percentage when cold. the radio messes up if its weak. Mine would do basically the same thing when my battery was below about 60%
 

·
Registered
Joined
·
40 Posts
Discussion Starter #4
Hi Rochev,

The battery is actually less than a year old. I had to replace it last year when a faulty stop light switch on the brake pedal caused the old one to die.

Right now I'm trying to decide between getting another factory radio from eBay, ($50.00 USD), or finding an aftermarket radio that will probably be less of a problem in the long run. I have an early 2011 that doesn't have a backup camera system, so it might be easier to find a radio,

215931
 

·
Has It Been That Long?
Joined
·
12,036 Posts
This seems like an APIM problem. They’re a bit finicky, especially from car to car.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #6
Hi White Falcon,

what is an APIM problem?

(EDIT) I did some Googling and the only references to the APIM problem seem to involve the systems with a display. My Taurus only has the basic system. I'll try the hold the seek and power button at the same time trick and see if it works on my system.
 
1 - 6 of 6 Posts
Top