Taurus Car Club of America : Ford Taurus Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
About a month ago the windows on my 2004 ford taurus vulcan engine started randomly not working. Then they would randomly start working again. I had not had any problems with them for a while and then today the car was running fine and then it died on me while I was putting it into drive. It read "low oil pressure". I turned the car off and checked the oil and it was fine. Started it up and it ran fine. I then filled up my gas tank and started to drive off and when I put on my brakes it died again, this time it said "check brake system". I turned it off ,restarted it and began to drive again and it ran fine for alittle while. I had my AC on and had stopped at a stoplight. When I started to take off it had trouble accelerating. I turned the AC off and it felt like the engine had a burst of power and picked up speed. Alittle further down the road it started flashing "check brake system" and unlocking and locking the doors about three or four times. I turned into a parking lot and put my brake on only for it to die again. I turned it on and it said again "low fuel level". It showed 10 miles from empty and slowly went back towards full. Did a scan on it and it came up with no codes. What could it be? Please Help!
 

·
Registered
Joined
·
3,377 Posts
could be a couple of different things. the easiest. bad battery, have the battery load tested. bad grounds or battery connection.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
Got a brand new Interstate battery in it, but will check those like you suggest. Would a bad master window/doorlock switch, mounted on the driver side door armrest cause these symtoms? The windows would intermitently stop working and then they would start working again. This happened about a month or so ago. Everything was fine until today.

Thanks Mike
 

·
Registered
Joined
·
3,377 Posts
this one is strange or sure. it could be a couple of different things. if the switch on the drivers door was bad then the switch on the pass door should work and with the other problems you had im thinking its related. I dont want to give you the wrong info. i remember someone else having a problem like this but cant remember who. there are a couple guys on here who are great when it comes to. electrical
 

·
Registered
Joined
·
3,377 Posts
It could be the VSS....what was once known as the neutral safety switch. It can cause many strange things to happen.
thats it. trs kept coming into my head and i knew that wasnt right. but what about the stalling? is that another possiblity of a bad vss?
 

·
Registered
Joined
·
23,579 Posts
Trs (transmission range sensor) = nss (neutral safety switch). Iirc, trs and nss are also referred to as the mlp (manual lever position switch). Vss = vehicle speed sensor. First, i would have the battery load-tested for free at a parts store.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #10 ·
Went and had the system tested under load. They put a voltmeter on the battery and had me turn on the AC and headlights while it was running. It was reading 12.6 and was slowly dropping. So I took off the alternator and had them bench test that. It was showing that the diodes were possibly bad, so I told them to go ahead rebuild it.

Update: Put the rebuilt alternator back on and now it reads a steady 14.4 volts at the battery with everything on running. Even put the old window switch back in and seems good so far.
Thanks for the help everyone, your advice paid off.

Thanks Mike
 
1 - 10 of 10 Posts
Top