Taurus Car Club of America : Ford Taurus Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
When at 40mph(roughly) if I punch it to drop into the lower gear, when the rpm reaches around 4k it starts chugging and it'll keep chugging. Not until I let off the gas and get back on it does it stop. It feels like it's suffocating or not getting any fuel. Anyone have any ideas? For reference the car is a 2003 ses ffv.
 

·
Premium Member
Joined
·
7,048 Posts
Engine light?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
QUOTE (rudedog @ Jun 20 2009, 10:43 PM) index.php?act=findpost&pid=733922
whats the condition of maintenance?? when was the last fuel filter changed?[/b]
I brought it to a dealer and they went over it last year. They couldn't figure it out. The injectors were removed & cleaned, fuel filter was changed. I did have a problem with the fuel level sending unit under the dash(which gave me a check engine light, so it was changed), and it helped the sputtering a little.
 

·
Registered
Joined
·
145 Posts
i'm having a similar issue but mine did pop up the idiot light. it's got an over all rough idle on my 96 ranger. I was driving down the highway and all of a sudden it just started shaking. (sorry don't mean to hijack the thread but just looking for input as well) the whole motor and muffler shake.
 

·
Premium Member
Joined
·
14,126 Posts
I've seen fuel pumps that would fail at high load and higher vehicle speeds.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Ok guys, I changed the spark plugs, ignition wires, oil change, and fuel filter. The chuging/sputering still happens right around the 4,100-4,900 rpm. It sometimes doesn't do it.
 

·
Registered
Joined
·
1,584 Posts
How many miles are on the car, and when was the last time that you changed the Synchroshaft and CPS?

Is the speedometer working correctly?
 
1 - 10 of 10 Posts
Top