Taurus Car Club of America : Ford Taurus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
Ok , So on the way home i noticed that when i punch the gas pedal my car spit and sputters alittle, also when pulling in my driveway i punched the gas alittle and i heard a little backfire,. My question is could this be the plugs and or wires or could it be the EGR doing this.

I have replaced the EGR gasket , TB gasket , PCV , valve cover gaskets and taped up some vacuum lines with hose tape.

The is a 96 Taurus 24v DOHC Duratec
 

·
Registered
Joined
·
3,686 Posts
First off, replace the damaged vacuum lines - just taping them up might not be good enough. Next, is the check engine light on, and if so, what's the code? It's not likely to be an EGR problem since the EGR valve doesn't open on accel - it opens while you're cruising. Misfires on accel are usually caused by the ignition system, so yes, bad plugs and/or wires could be the cause, along with a bad coil pack. When's the last time you did a tune-up?
 

·
Registered
Joined
·
90 Posts
Discussion Starter #3
No codes , i haven't done a tune up on the car , i just got it about a week ago

I read that a bad fuel filter will also cause this so i think i will start there and see.

As far as the vacuum lines i haven't found a source for them , they are thin plastic and some are rubber with bends in them not to mention the rubber boots.

If the Filter doesnt do it then its a 300.00 tune up for me
 
1 - 3 of 3 Posts
Top