Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
946 Posts
Discussion Starter #1
This has been happening one an off for a while now and I wanted to know if there is a way to fix it? The needle will stick for a bit, then work fine for days and days. When I dropped it off Monday to get repaired, the needle was and I am sure, is still stuck. If you tap it, it will move.

Is there a fix? I wouldn't really care and I would just swap it out with another speedo that I have, but its an SHO speedo and those aren't easy to come by.

Thanks for the help!

Kris
 

·
Premium Member
Joined
·
14,126 Posts
The needle may be rubbing on the face of the gauges. You need to get to the needle and pull it away from the face, they just press on. Be careful to not pull it all the way off or you will lose your calibration.
 

·
Registered
Joined
·
183 Posts
did u by any chance put glow gauges in. cuz mine started sticking too. what u gotta do i hot glue the new guages around the ring where the needle pops out hot clue is easy to get off if u want to remove them in the future. it worked for me. or u could always pull the needle up a lil.
 

·
Registered
Joined
·
946 Posts
Discussion Starter #5
No new aftermarket guages. Only thing was I popped the needle off a few times with brute force, but after disasembline and tearing apart another speedometer, I shouldn't have hurt anything. I took it apart and drove around. Looks like its working ok I think, but sluggish on the higher readings.

Who knows.
 
1 - 5 of 5 Posts
Top