Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi guys. Its been quite some time since I've posted here. So long in fact that I actually had to register a new account. I used to be known as 'obelix', if anyone remembers. Anyhow, it's good to be back online and back at the TCC.

Now here's my question. A couple weeks ago, I started my car up in the morning, in cold weather and all seemed fine. Once I made my first turning signal of the day (right), the blinker in the dash started blinking really fast, about twice as fast as usual. I have since observed that my rear right signal light is not functioning and my front right signal is going twice as fast as normal (like the dash light). I guess my real question here is what is wrong? Is it just a burnt bulb? Do i have a loose connection somewhere? I have checked my fuses and everything seems to be fine there. Also, if it is a bulb that needs changing, would someone be able to give me a brief walkthrough on how to get everything apart in order to make the change. Thanks for your time and advice guys. It's nice to be back
 

·
Premium Member
Joined
·
2,545 Posts
u need to take the whole back tail light off screws in trunk then u just turn the knob where the light of the burn bulb is and put a new one in
 

·
Registered
Joined
·
369 Posts
Most Definitely the bulb.

BTW, Welcome back. What color is your 92' Sable?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
hi guys. thanks for the quick responses. i plan on getting a new bulb and changing it tomorrow after work.

slider5634: My sable looks to be damn near the same as your avatar. white with grey trim.
there's a front bumber shot in my signature.
 
1 - 6 of 6 Posts
Top