Taurus Car Club of America : Ford Taurus Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter #1
My 98 Taurus (Vulcan) just the Service Engine Soon light on today. I have it checked out at Autozone. It turns out to be PO411 which is secondary air injection system incorrect flow detected.

Anybody knows how to fix this?

Thanks for your input.
 
B

·
Guest
Joined
·
0 Posts
DTC P0411/P1411 indicates Secondary Air not detected. In order to test the pump, it must be capable of driving the HO2S lean.

NOTE:
Some applications have one or two AIR diverter valves.

Possible causes:

-- Electric AIR pump fault.

-- Hose from electric AIR pump blocked.

-- Hose from electric AIR pump leak.

-- AIR bypass solenoid stuck open/closed.

-- AIR bypass solenoid leak/blocked.

l Visually inspect electric AIR pump hoses from the electric AIR pump to the AIR diverter valves.

l Inspect air hose for cracks, binding, obstructions, water or ice.

This is a cut and paste from the service CD. I have the same code from time to time, in my case the hard line from the front manifold to the diverter valve is broken. It didn't affect the way the car ran, so I haven't gotten around to fixing it yet.
 

·
Registered
Joined
·
241 Posts
Discussion Starter #3
Is it a big problem? Do I need to fix it right away?

I can't really feel it maters.
 
B

·
Guest
Joined
·
0 Posts
Originally posted by batrachian@Sep 28 2004, 09:35 PM
Is it a big problem? Do I need to fix it right away?

I can't really feel it maters.
It hasn't ever affected my car's driveability at all, however if you're due for an emissions check soon, most places won't do it if the SES light is on.
 

·
Registered
Joined
·
241 Posts
Discussion Starter #5
Is there a way to fix this by DIY?
How hard it could be ?

thanks again.
 

·
Premium Member
Joined
·
2,458 Posts
Just disconnect the SAI. That will get rid of the CEL and code, and since emissions tests aren't done on a cold engine, you have nothing to worry about.
 

·
Registered
Joined
·
241 Posts
Discussion Starter #7
The light went off just now. Actually, I didn't do anything at all.
What could be the reason? Is it going to come back on again sometime later?

Thanks
 

·
Registered
Joined
·
241 Posts
Discussion Starter #8
My Bull still have several months' warranty. Is this a big problem?

Any suggestions on if I need to have it checked when it is still with warranty?

Thanks.
 

·
Registered
Joined
·
241 Posts
Discussion Starter #10
The service light back on again. after 4 weeks And it seems there is something wrong.

Do I have to replace the O2 sensor??

:notworthy:
 

·
Registered
Joined
·
3,686 Posts
If you still have warranty, take it back to the dealer and get it fixed for free. Why bother wasting your own time and energy trying to repair it or work around it?
 

·
Registered
Joined
·
241 Posts
Discussion Starter #12
The thing is I got this car second hand. The warranty seems to require mantainance record which i don't have.

Just wondering if i need to try my luck to see if dealer really needs it.
 
1 - 12 of 12 Posts
Top