Taurus Car Club of America : Ford Taurus Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
hi everyone, i have this problem with my car: recently i have noticed a little effort from the engine to move the car, on uphill the car seem to pull a heavy weight, then the rear rigth tire start to smell as a cloud of smoke scape from it, so i take a look and see that damn tire was hard to rotate, because the brakes were jammed, so i changed the brarks pads and lube the pins well enough thinking that the problem was solved...

but now i got the four wheel hot! and a little smell of burned pads... the most from the same tire and the front left, those seems very hot at touch tought the car still run with a little effort some times...

and sometimes the brakes aren't hot and the car rides smooth, but on most of the time the brakes are 'braking' the car a little. what could be?

any help!
 

·
Premium Member
Joined
·
1,005 Posts
Could be too much brake fluid in the resivior, or a sticking caliper or a sticking wheel cylinder.
 

·
Registered
Joined
·
79 Posts
have you tried adjusting your parking brake? this may fix the rear, but as for the front is sounds like a bad caliper not releasing or "floating" right, maybe a jamed piston or 2. check and make sure your fluid is nice and clean and not green or brown should be clear. check your caliper pins and make sure the caliper actually moves.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #8 ·
:rolleyes: hum this is interesting, i'm gona check that tomorrow... but if the spring is worn, what have to do to change it? heck, wait a minute, if the pedal does not return to its zero position, then the brake ligths should be on right? and i havent see that, actually...
still im gona check...
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top