Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter #1
Popped the P0411 code for secondary air injection system incorrect flow, any idea what to check or what this menas??
 

·
Premium Member
Joined
·
2,458 Posts
Originally posted by mikehawk@Sep 24 2004, 09:47 AM
Maybe you have dirty butterfly valves in your lower intake manifold and they're stuck open or stuck closed.  Or maybe your IMRC box is broken.
No... the SAI is something different altogether. Other manufacturers call it an "Air Pump" or "Pre-heater" and it is unneccessary. All it does is pump fresh air into the exhaust stream for the first minute or two upon startup of a cold engine. This feeds oxygen to the cats and allows them to burn up the remaining fuel in the exhaust stream, thus heating the cats and the O2 sensors so the emission system becomes fully operational much faster.

Uplug the SAI and forget about it. You won't have any codes or problems with emissions, since emissions tests aren't done on a cold engine anyway. Many SHO guys have done this when the SAI shits the bed.
 

·
Premium Member
Joined
·
14,126 Posts
The electric pump has a soild state relay under it. This is usually what goes bad.
 

·
Registered
Joined
·
1,963 Posts
Can this affect idle quality while the engine is cold? I have a P0411 and the idle quality sometimes flutters but it improves once the engine is warm after a few minutes.
 

·
Premium Member
Joined
·
14,126 Posts
The electric SAI is only operating when the engine is first turned on, first 20 to 120 of engine operation. You may have a vacuum line off on the switched side of the vacuum solenoid. This would explain a code and a poor idle while the SAI is suppose to be in operation.
 
1 - 6 of 6 Posts
Top