Taurus Car Club of America : Ford Taurus Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Need advice please..I have a 2001 Sable LS Premium 3.0 durotec 24 v ohc engine.154,000 miles.previous owner had same probs. Unable to have fixed.
Under load mostly and occasionally while idleing, I experience a miss.It's not constant and it doesnt change the rpm or give a fault, check engine light, other than twice the engine light flashed a couple times then went off while acceleration to get on interstate with a/c on.
Prev. owner had mechanic change plugs, wires, coil pack.didnt help.I took it to a mechanic, and they somehow said i had a misfire on cylinder 3 so they changed plugs /wires & new intake manifold gaskets again. I've tried Lucas injector cleaner, just so I can say I tried something.
Previous owner was my mother-in-law whose just bought the car a few days b4 my father-in -law passed away & couldnt afford payments & hit & miss repairs on this problem so I bought it off her.
I dont want to take it to a dealer or give it to another garage just to keep throwing parts in hoping to hit the problem.
Any advise would be greatly appreciated.besides it would get the mrs off my back to figure it out.
 

·
Registered
Joined
·
448 Posts
Most likely it's the coil pack. Take it out to see if there's crack ANYWHERE on the coil. These things are notorious for cracking and causing weak spark.

Could also be fuel injector... but more unlikely than coil.
 
1 - 2 of 2 Posts
Top