Taurus Car Club of America : Ford Taurus Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter · #1 ·
Hey,
I'm having trouble keeping the molding around my glass from turning to a nasty tan color, instead of the normal black. Is there anything anyone's used to restore the rubber? I have a 96 GL. My car is black and this makes it look like it is dirty.

Thanks in advance

joe
 
G

·
i used armor all wipes on mine... had it on there for over a month and still looks great (even after being through some weather) - might want to try that...
 

·
Premium Member
Joined
·
882 Posts
A friend of mine has a 99' SE with the same problem. It looks like some kind of mildew or something. He hasn't bothered to take it off, I guess he is too busy. I think a medium grade green scrubbie pad could work. I have some window cleaner from Rain-X that is very abrasive and it could work too. Just follow up with some good soakings of Armor All. I haven't tryed this so if you do just do a small spot to see what it does.

Just my .02
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #6 ·
SFBLACKSEL,
Your idea worked like a charm! I got a green scratch pad and some bon-ami cleanser. And it cleaned that brown gunk off the rubber moldings! I put some STP protectant after cleaning the residue off and it looks almost new! You guys ROCK!!!!

Joe D.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top