Taurus Car Club of America : Ford Taurus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
If I'm driving at a constant speed remove my foot from the accel. The engine surges between 1500 and 500 rpm, untill it reaches about 20 mph. All the way down to 20 mph the surging rpm decreases also. HELP any one have any ideas. The engine has died a couple of times when in a rush hour traffic situation.
 

·
Registered
Joined
·
833 Posts
I'm sorry but the whole English thing seems like it didn't want to translate your thought through the keyboard. Do you mind trying to explain this a little better?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
It seems when I drive along and remove my foot from the gas pedal the engine slows the car down normally until it reaches around 30 mph then it surges between 1100 rpm and down to 450 to 500 rpm. It is so low that at the lowest rpm my oil light flashes for a split second. Then at about 20 mph the surging dies down to a normal idle. If I put the car in neutral (just trying to isolate the issue and figure out what is up), the engine drops down to about 600 rpm surges up to 1500 rpm and will continue to reduce the upper rpm of the surge till I coast down to 20 mph and the engine will idle normally. Everything operates fine under hard acceleration. It's extremely annoying in rush hour traffic when I reach 30 -35 max, have to take my foot off the gas pedal and coast the engine almost dies (and it has a few times but not consistently) and surges up to about 1100 rpm and back down to 450 rpm. I hope I gave you enough explanation.
 

·
Registered
Joined
·
833 Posts
hmm... that's wierd. Start with the easy stuff, check your oil and transmission fluid levels. engine off for oil, running and hot in park for trans. Go to the parts store and have them check for codes, current OR PENDING codes. That's all I've got for, sorry I'm hungover. Start with checking for codes and get back.
 

·
Registered
Joined
·
23,355 Posts
Might clean/replace iac (idle air control), check/replace tps (throttle position sensor) and check for vacuum leaks. Check engine light on?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
when I am at a complete stop, it idles fine. When i am rolling 20 mph, it does not surge.. 30mph, it start surging with a 200 to 300 rpm shift.. 40mph more fluctuation.. at 50 mph, throw the car in neutral, the rpm changes surges 400 rpm to 1500 rpms... odd that it is directly related to speed of the vehical... When I slow (while in neutral) to 20 mph, there is no more surging......I will check what was noted, but wanted to clear up where the surging was occuring...

Thanks
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Sorry I forgot to include no check engine light on. The only code that was thrown a couple of weeks ago was a fuel level sensor malfunction.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
OK... How do I test the Throttle Position Sensor and the IAC?
Does anyone have a picture of these and where they are located?

Thanks
 
1 - 8 of 8 Posts
Top