Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
 

·
Premium Member
Joined
·
9,959 Posts
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
[/b]
How many miles? How has it been maintained?

P1151 Lack Of Upstream HO2S Switch, Sensor Indicates Lean, Bank No. 2
 

·
Premium Member
Joined
·
987 Posts
<div class='quotemain'>
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
[/b]
How many miles? How has it been maintained?

P1151 Lack Of Upstream HO2S Switch, Sensor Indicates Lean, Bank No. 2
[/b][/quote]
OMG getting advice from the king himself. legendary :notworthy:

 

·
Registered
Joined
·
9 Posts
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
[/b]
90% of the time its the PCV system. I don't know if the 2000 is different than our '98 Duratec Sable ,but the elbow that receives the PCV valve swelled and didn't provide a airtight seal and it threw same code and ran rough
cold with misfire under load. Threw a clamp on the joint making sure the PCV is seated before tightening.
It's not the easiest clamp install (2 extensions on my 1/4" ratchet) but it was easier than taking the UM
off and r/r suspect rubber elbows and hoses.

Best of luck,
MustangScott
 

·
Registered
Joined
·
53 Posts
Discussion Starter #5
<div class='quotemain'>
My wife 2000 sable wagon with the duratec ran really rough this morning , but was fine once it warmed up.
I looked down to see the check engine light on. Went to autozone and got this code p1151.
Autozone was not much help, Any ideas.
thanks
[/b]
90% of the time its the PCV system. I don't know if the 2000 is different than our '98 Duratec Sable ,but the elbow that receives the PCV valve swelled and didn't provide a airtight seal and it threw same code and ran rough
cold with misfire under load. Threw a clamp on the joint making sure the PCV is seated before tightening.
It's not the easiest clamp install (2 extensions on my 1/4" ratchet) but it was easier than taking the UM
off and r/r suspect rubber elbows and hoses.

Best of luck,
MustangScott
[/b][/quote]

Car has 144,000 miles on it and has been maintain well.
Pcv valve and hose are new as well as the other vacuum lines that usaully rot away.
 
1 - 6 of 6 Posts
Top