Taurus Car Club of America : Ford Taurus Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
2006 taurus,has very rough idle,no engine codes,so far i have replaced iac,maf sensor,fuel filter,air filter,replaced intake gaskets,spark plugs,checked egr,and replaced imrc gasket.and cannot find any vac leaks.please help.
 

·
Registered
Joined
·
1,392 Posts
Take off the ignition coil pack and take it into Autozone and have them bench test it, they do that for free. Another thing to look into is the dpfe sensor, Ford's dpfe sensors often fail, and don't always throw codes. When they do, it's usually a egr code. Did you replace the plug wires when you put new plugs in, if not did you check the resistance before re-using them?
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 ·
QUOTE (austex04 @ May 22 2010, 06:48 PM) index.php?act=findpost&pid=806124
Take off the ignition coil pack and take it into Autozone and have them bench test it, they do that for free. Another thing to look into is the MAP sensor, Ford's MAP sensors often fail, and don't always throw codes. When they do, it's usually a egr code. Did you replace the plug wires when you put new plugs in, if not did you check the resistance before re-using them?[/b]
thanks,i will try the coil pack tomorrow,also the taurus does not have a map sensor,its has the maf sensor and i replaced that already.any other possibilities? i was thinking maybe fuel pressure but it has an electronic fuel pressure regulator,and no pressure port on the fuel rail
 
1 - 3 of 3 Posts
Top