Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Does anyone know how to gain access to the spring lock connector to remove the low side hose from the evaporator? The connector is stuffed right up against the firewall and surrounded by wiring making access extremely limited. Any suggestions out there? I have considered cutting the existing hose and splicing it onto the new accumulator hose, but only as a last resort.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Have not tried that yet...it seems to be the only way to gain access to the connector...thanks for the suggestion.
After removing the plastic cowls I was able to access the connector but the crummy plastic Harbor Freight release tool (3/4") doesn't do the job. Of course they worked just fine on the easy access connectors but this one won't release. I can't hear or feel the spring being expanded. Can you recommend a better tool?
 

·
Registered
Joined
·
57 Posts
You can also disconnect the wiring harness that's in the way and fold it out if the way. I think it's a single 10mm bolt. I did that and took off the plastic cowels mentioned earlier. That gave me plenty of room. I also used a cheap harbor freight disconnect tool as well.

Good luck.
 

·
Registered
Joined
·
6,897 Posts
May also pm member Automender12345. Iirc, he's tackled this r&r.
I have done this on a 2006 because of a rust pin hole in the accumulator. I remember it being a pain but was able to do it without removing cowlings but moved some wires around I used a quick release but not sure of the brand but I attached pic below.
 

Attachments

1 - 7 of 7 Posts
Top