Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
ok i have a 96 taurus 3.0. i cannot hear the fuel pump turn on even after changing the pump and filter. it has new spark plugs and wires. the inertia switch was not tripped and the relay is good....however i am not getting any power to the inertia switch or pump. if i ran a wire from a fuse to the inertia switch and turned the key the pump fired up but the car will not crank. i do have a blown fuse but it keeps blowing every time i put one in. i traced the wires to what im told is a RELAY CONTROL MODULE. before my car quit running it was making a bad humming noise which i am also told was the RELAY CONTROL MODULE. would i be correct in assuming that if i replace the RELAY CONTROL MODULE then the fuse would probably no longer blow. then i could replace the fuse and the car should start??
 

·
Registered
Joined
·
2,471 Posts
Disconnect the CCRM electrical connector, install a new fuse, circuit breaker, or connect a 12 volt test lamp across the fuse contacts & see if it lights up, or if the fuse blows, or cb trips.
If it does, the problem is in the wiring to the CCRM, not likely the CCRM, unless Murphys Law is messing with you & you have two problems!!!!!

The search function is your friend, from a link in the forum wikki, here is how to check out the CCRM
http://www.taurusclub.com/forum/98-...-how-articles/121857-ccrm-test-procedure.html

Some thoughts to get you started, let us know how it goes.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
but if my ac compressor isnt turnin on either and i have had problems with a hummin noice which im told is the ccrm then its more than likely the ccrm correct?
 

·
Premium Member
Joined
·
5,895 Posts
It could very well be. There is a bit of testing you can do to test the CCRM. If I was home I could post the wiring diagram of the CCRM internals, but I'm at work now. Perhaps someone else here has something of the sort to help.
 

·
Super Moderator
Joined
·
8,586 Posts
If the CCRM is buzzing, the problem is very likely a bad ground, and not the CCRM itself.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
ok there is a short somewhere in the wiring. i replaced the ccrm and the fuse. when i turn the key foward the pump turned on but as soon as i crank it the fuse blows and the car wont start. so the short is somewhere btwn the fuse and the ccrm correct? and where is the ground wire?
 
1 - 7 of 7 Posts
Top