Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
702 Posts
Discussion Starter #1
My radio hasn't been working for quite a while. I have an older cd player mounted under the dash till I can get the other one working.

I have electronic climate control and it works fine, all the buttons light up on the climate buttons and on the stereo buttons, but I cant even turn the radio on. I think its a power issue, but I have no idea. And yes, I've tried all the fuses- even the ones under the dash.

Any suggestions?
 

·
Registered
Joined
·
702 Posts
Discussion Starter #2
I painted the face to the stereo, but it didn't work even before I did that.

 

·
Premium Member
Joined
·
2,090 Posts
well, the radio under the dash needs to be unpluged at the connection in the trunk and the factory wiring pluged back in. Then it will power up (the speakers and power for the rear control unit are all in one.)

Brad
 

·
Registered
Joined
·
702 Posts
Discussion Starter #4
The only reason I put that in there is because the stock stereo wasnt working. I doint think the guy who installed it actually dissconnected the stock stereo, so it should still work.
 

·
Premium Member
Joined
·
2,492 Posts
He had to disconnect the stock radio to get the other to work. The speaker controls and attenna adapter are in the trunk. There was a wire he had to run from the trunk to the under dash to connect it to the speakers. If you pull the driver side carpeting out of the trunk you'll see the wires.
 

·
Registered
Joined
·
702 Posts
Discussion Starter #6
Yes, but the reason I had another stereo installed under the dash is because the stock radio stopped working. With "electronic climate control," the three words of doom, I cannot install an aftermarket stereo. **sigh**
 
1 - 6 of 6 Posts
Top