Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have 2013 SEL Taurus, it was sitting about 1-2 months, battery was dead and I started it with jumpstart.
I can control my radio and climate control with steering wheel and with touch screen, but buttons under touch screen doesnt work. I tried unhook positive terminal from battery, then I press 3 timesstart button and SYNC just restarted, but it didnt work. I can only turn OFF/ON radio with round button, nothing else. I am adding pic of my unit
216672
 

·
Registered
2013 SEL
Joined
·
405 Posts
Had a similar issue, but it was only the lower right quadrant that didn't work right (seemed to vary, based on temperature. Posted about it here: Strange center console electrical problem

Thanks to parking for a couple of months (and a dashcam that someone plugged into the wrong port, so it was on the whole time), our Escape battery died. After charging it back up, there was some odd console behavior. Still under warranty, we let the dealer take a look at it. They said they reset the computer, twice, then it started behaving correctly.

Dunno if these are related or if they will help, but maybe it'll start conversation.
 

·
Registered
Joined
·
50 Posts
Had similar issues. Capacitive buttons were freaking out like a button was stuck down and would not respond to input. I think the face plate with the buttons was replaced under warranty at the time. This also affected my hvac controls at times.
 

·
Registered
Joined
·
130 Posts
Usually a module reset of the FCIM will take care of this, you can do that with ForScan.
The second step would be to use ForScan and check the AS-Built against the current config to see if something doesn't match.
 
1 - 4 of 4 Posts
Top