Taurus Car Club of America : Ford Taurus Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello This is my first post on this forum and I have only been on this site for two days and have found super helpfull info on the froms already so with that being said I bought my 95 SHO with the 3.2swap and the 3.0 cam conversion and motor has relitivaly low miles on the rebuild but I am finding little "shortcuts" in the car, for example the ECT was disconnected and the fan was rigged up with a toggle switch? The car is throwing a code about 15min into driving it and is coming up with a lean 02 right and left or front and rear either way but could an unplugged ect make her run lean and throw a code? Also on the fire wall there is a vacume log with 4 ports on it and the two middle ports are capped off? I just replaced the "ACT" air charge temp sensor and noticed a lil improvement and the pluged a barely hanging on vaume cap under the throttle body on the bottom side (the two vacume ports both were capped?)I am not sure if they are suppost to be plugged but the car has a sputter when coming from off idle but when it get going and you hear those secondaries performance seems right there? the occasional stumble at the high end but runs good for the most part. If anyone could offer me some first time SHO buyer advice on this one I would really apreciate it. PS the price 0n some of these parts is CRAZY! but yet I am still getting atached to the red dragon each day! Thanks again Ian.
 
1 - 1 of 1 Posts
Top