Taurus Car Club of America : Ford Taurus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 04 sel taurus with electronic temperature controls. I had my engine washed after getting a power steering pump repaired. While I was driving later that day the radio got stuck on a station and would not change. I pulled over and turned the car off and back on. Now my radio is dead, will not turn on and the heat is stuck on. It is in defrost with the heat on and will not respond to the temperature controls. The closk in the radio is alo off. The radio is the one with cassette and cd changer in the center console. The etc controls light up and i can set temperature but it does not respond. Now that my warranty is over is there anything that I can do? Removed batery cable, same problem
Hope someone can help me because it is getting warmer and haveing the heat on as soon as i turn on the car is a problem.
Please let me know if you need more information
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
QUOTE (Qwertz9586 @ Apr 4 2009, 02:06 AM) index.php?act=findpost&pid=715111
Are your power windows acting up too (not working properly or controls not lit)?[/b]

No the only problem was with the temperature controls, and the rario only. My dad was able to repair this, he is a mechanic (but hates ford cars). He said he played around with some of the sensors to get it to "reset". Apparently this is by design on ford the taurus. When the EAC gives a problem or is about to fail it defaults to full defrost, so that if it was winter you would be able to at least drive the car. Sucks if this happens in the the summer through.
 
1 - 3 of 3 Posts
Top