Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
The power steering pump on this thing has always been a little noisy...not whiny but more like bearing noise. About a week ago I started noticing the occasional squeal when turning the wheel but it seemed to go away after the car warmed up. Well, two days ago I went to back out of a parking space and when I turned the wheel I was greeted with a GRONK kind of noise along with the squeal. It has done this a couple of times since then and now the pump squeals pretty much any time there is a load on it.

I've replaced the fluid twice in the last 2 days and it is toasting it almost immediately. Looks like I'm up for replacement but I just wanted to see if there is anything in the rack I should be checking as well before I make the assumption that the pump is the only problem.

I can't afford a brand new pump, so if anybody has a good review on any of the remanufactured ones available I'd appreciate it. There's NAPA, Advance Auto, Auto Zone & Champion here locally and Rock Auto online.

Of course this comes shortly after I ordered new plugs, plug wires, cap/rotor, tranny filter & pan gasket from Rock Auto. I'm doing the plugs tomorrow and the tranny/power steering pump next Saturday.

Then the paycheck after that will be spent on parts to fix the timing chain cover gasket leak, plus a new water pump, lower radiator hose, timing chain & rod bearings.

I mean, I love my car & all but why does she feel the need for all this attention at once?

My poor wallet... :p
 

·
Registered
Joined
·
19 Posts
Good news, I'm an A.S.E. parts pro for Napa, I'll ckeck it out for you on Tuesday, and give you the price,(off tomorrow and Monday). But the one You'll get from Napa will have a lifetime warrenty. You'll also need to buy or borrow a pulley puller/installer set because the pump doesn't come with the pulley. Also get the pump with the resivor installed, the price diff. is minimal. Your current pump has a smoked bearing, thats the gronk sound now, and the reason for the previos humm/whine, and also its the cause of the burnt fluid. Man, I can't spell for crap!!!!!!
 

·
Registered
Joined
·
108 Posts
Discussion Starter #3
Ok...looking through the Chilton's to give myself an idea what I'm in for, one of the first steps after removing the passenger side wheel/tire:

"Remove right rear engine mount....."

:blink:

Is this really necessary? 'Cause looking at the steps for THAT I might be in over my head. ("using engine raising equipment raise the engine approximately 1"...)

Another question: I took the belt off and checked the play in the pulley on the PS pump. It has about 1/16 to 1/8" play in it. Is this normal or just another indication that the thing is borked?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #4
I wasn't sure if I could do this myself and the pump was dying quickly so I took it to the shop that my family & I have gone to for over 10 years.

They put on a reman Motorcraft pump and new pulley. Picked up the car & drove it home. Opened the resevoir and saw dark fluid. (no, not dark red like atx fluid) This appears to me that they did NOT flush out all the old fluid which I thought was a must-do when swapping the pump or rack & pinion and just let the new mix with the old burnt stuff.

Today the pump starts squealing a bit like there is air in the system. Which according to what I've read requires some vacuum tool to remove. Could this have been avoided if they had flushed the [email protected]#$% system like they were supposed to? Or is there a possibility that there is a problem with the rack & pinion that could be causing problems? I kinda want to know before I take the car over there next week and start calling him names.

I mean charge me $10 for p/s fluid and only replace $1 worth in the resevoir? Gimme a [email protected]#$% break!

I'm just as much disappointed as I am pissed off. I've never had a problem with their service before but I guess there's a first time for everything. :(
 

·
Premium Member
Joined
·
2,277 Posts
..when i had my rack replaced i had to add fluid a few miles later.... to "bleed" the power steering system, remove the cap off the reservoir , and with the car running, turn the wheel to the right and left several times, DO NOT turn all the way tho to the point the wheel stops. Do this a few times and the air should work its way out. As far as the fluid looking dirty, it may have just picked up contaminents in the system...ive never seen clean clear power steering fluid except for mine, but my rack was cracked and the bushings were non existant and all the fluid had sprayed out...
 

·
Premium Member
Joined
·
2,492 Posts
sandrew, when the PS started to the the gronk noise, did you also notice when you would turn to the right that it felt like there was something bouncing on the steering wheel?

I ask because my sister's 93 Taurus GL makes the squeal and gronk noise. When turning to the left feels fine, turning right it feels like there is something bouncing agains the steering column. I was curious if that was caused by the pump (which I knew was bad months ago), or the more likely senario, something deeper.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #7
tmonster: I'll have the car up on jackstands this weekend to replace the tranny fluid - I'll try your suggestion and hopefully it'll take care of it.

EDIII: No weird vibrations or movements accompanied the noise, just a very brief hesitation in the power assist.

Again, thanks to all on the boards for your help. :)
 
1 - 7 of 7 Posts
Top