Taurus Car Club of America : Ford Taurus Forum banner

21 - 28 of 28 Posts

·
Registered
Joined
·
2,435 Posts
Discussion Starter #21 (Edited)
Bump:
Well here it is 2016 & the 94 Taurus & 99 Ranger power steering systems are still doing fine, no return of off center loss of boost, or shudder on either vehicle After installing a Magnefine inline filter in their power steering return line 8 years ago.
It's time to replace them & when I do I'll open them up & post photos of anything the filter media, or magnet has captured. The fluid in both systems is still clear red.
 

·
Registered
Joined
·
9,636 Posts
Bump:
Well here it is 2016 & the 94 Taurus & 99 Ranger power steering systems are still doing fine, no return of off center loss of boost, or shudder on either vehicle After installing a Magnefine inline filter in their power steering return line. It's time to replace them & when I do I'll open them up & post photos of anything the filter media, or magnet has captured. The fluid in both systems is still clear red.
I suck out the fluid from the resivor each fall and replace it. Takes maybe a pint. Stays clean, never had a PS issue: 8 Bulls, 5 Lin Cont.

Well, not never, had a seal leak on '01 and put a new shaft seal in. Car sold. = '01 DOHC. 131K

-chart-
 

·
Registered
Joined
·
2,435 Posts
Discussion Starter #24
What is this cylinder? Is this a power steering filter, too?
Look on page 2, post 18 of this thread, for the factory power steering filter location & what it & the Magnefine filters look like.
 

·
Registered
Joined
·
546 Posts
Don't forget to inspect and clean the mesh "filter" screen at the bottom of the reservoir.
 

·
Registered
Joined
·
2,435 Posts
Discussion Starter #28
BUMP: !0th year Update!!!

!0 years & 5 months ago I cleaned/flushed the 94 Taurus & 99 Ranger power steering systems with Sea Foam Trans Tune, the specified licensed fluids & added a Magnefine inline fluid filter to the low pressure/return lines after the fluid cooler, to see if it would make any positive difference in the intermittent returning loss of boost & or off center shudder both systems developed, even though both were getting a Full system fluid flush every 30K miles when the tranny in both vehicles got their pan drop, filter change & full fluid pump outs & in spite of the fluid maintenance Both power steering systems developed the same problems.

As reported over the years, after the Trans Tune flush, filling with the specified fluids licensed to meet Fords specifications & adding the Magnefine inline filter back in 08, both systems have remained trouble free for 10 years & 5 months now. Both pumps remain quiet. The Taurus pump Really got quiet after its service in 08 & remains so. The Ranger pump never has been noisy like the Taurus pump got, but as mentioned it too developed the intermittent loss of boost & off center shudder but hasn't returned after adding the inline Magnefine filter.

Magnefine has moved their manufacturing to the USA & now has a Metal body filter housing, so I'm about to change both filters to the new design, as both are 10 years old & close to 30K miles on them, so time for a change.

As mentioned a couple of years ago I'll open both filters & inspect the media & magnet for debris to see if anything obvious turns up & will post some pictures on this thread as a update for the record.

Right now I have no idea why adding the filter seems to have fixed the problem, as both systems fluids looked & smelled fine & easily passed the poor mans blotter spot tests at 30K flush intervals. So we shall see if the filter media, or magnet reveal any suspects they've captured.
 
21 - 28 of 28 Posts
Top