Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
367 Posts
Discussion Starter · #1 ·
For the past year or so, every so often when I would be turning and driving slowly (like a drive thru) there would be a popping/clunking noise in the front left. Kind of shrugged it off but now its getting worse with repeated popping and it happens just about every time now. Replaced the endlinks a few weeks ago so I know it's not the endlinks. Also it never happens during higher speeds and it seems to happen more if i have more people in the car. Could it be a wheel bearing? Maybe an axle? Maybe you guys have an idea? :huh:
 

·
Registered
Joined
·
1,392 Posts
Mine has been doing that for almost 2 years now. It's probably the left strut plate on yours. Mine started with the right front, around 50k, and the past year now both of them make that pop/clunk sound whenever I go over any bumps, or turn the wheel from one side to the other. Ford struts are not the greatest, long lasting struts you would find in the aftermarket. I learned to live with it. If I do keep this car come spring, I'll replace my front struts with Gabrial ready-mounts, but I'm probably going to sell/trade in this car anyway, so no point in putting in new struts. I now have 107k on this car, only 2 minor issues besides the struts since 25k.
 

·
Devoted Member
Joined
·
2,426 Posts
Could be a CV joint starting to go (axle half-shaft). Do you hear it on the left when turning right, left, or either?
 

·
Registered
Joined
·
1,392 Posts
Another thing to keep in mind is you own a Taurus, and live in the rust belt. The springs often rust out, and go snap!
 

·
Registered
Joined
·
367 Posts
Discussion Starter · #5 ·
They already snapped 2 years ago so thats out of the question.
 

·
Registered
Joined
·
367 Posts
Discussion Starter · #6 ·
bump.. still have this problem
 
1 - 7 of 7 Posts
Top