Taurus Car Club of America : Ford Taurus Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
My 2000 Ford Taurus has 118K mileage on it. I have this car for three years. I changed its fuel filter and air filter last summer. Its engine light is on for two years. There are two error codes. One codes reads oxygen sensor or something. I can't remember exactly. The mechanic told me not to care about it.

During the past two months, the engine shakes periodically (once every 4~5 seconds) from front to rear when the car is at idle. I can see the engine speed jumps between 600~900 RPM when the car shakes. Occasionally the speed dropped to zero and the car stalled. I had to restart the car at green light.

I "Googled" and am puzzled at so many possible causes for a stalled and shaked engine. Please help make a diagnosis.
 

·
Registered
Joined
·
1,365 Posts
One codes reads oxygen sensor or something. I can't remember exactly. The mechanic told me not to care about it.
:lol2:

Get the codes and post them here. Most likely they do indeed matter.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #6 ·
It is a Vulcan engine. It is a 2000 car with 118k mileage.

Can you elaborate the vacuum leak that causes engine shakes and stall at idle?
 

·
Registered
Joined
·
619 Posts
Probably the most common on these cars...the PCV hose attached to the valve cover closest to the firewall.
 

·
Premium Member
Joined
·
1,283 Posts
BTW, your O2 sensor is shot. That code means the O2 sensor is not responding, should have been replaced 40,000 miles ago as a maintenance item. Replace both upstream O2 sensors and begin the vacuum leak hunt.

Also find a new mechanic. Any mechanic that tells you to ignore a problem is a problem himself.
 

·
Super Moderator
Joined
·
8,732 Posts
1 - 11 of 11 Posts
Top