Taurus Car Club of America : Ford Taurus Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
I searched before and found one thread about it on Mercury. I have a Vulcan 99 Taurus. I went to Auto-Zone and got both of the codes. :huh: While researching on the forums it is recommended to clean around the EGR valvce and maybe change the DPFE before replacing the actual valve for the P0401 code.

P0401

Blocked passage on EGR
Failed EGER
EGR solenoid faulty
Failed EGR pressure sensor


P1131

Lack of bank 1 02 transitions - lean limit

Misfire bank 1
Vacuum leak affecting bank 1
Fuel Injector bank 1
Engine mechanical condition

FWIW - I am in the process of changing the Temperature Coolan Sensor.


Thanks for any advice...:unsure:
 

·
Registered
Joined
·
2,425 Posts
You can check the EGR valve by sucking onto the small vacuum nipple on top (with engine at idle). Engine rpm's should change drastically if the valve is good.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #3 ·
You can check the EGR valve by sucking onto the small vacuum nipple on top (with engine at idle). Engine rpm's should change drastically if the valve is good.

Suck...you mean with a mouth...I'm not familiar with car lingo. :huh:
 

·
Registered
Joined
·
1,365 Posts
No, a blocked EGR wouldn't cause a lean condition. If the EGR passages are plugged, then the EGR test won't really prove anything. Which engine do you have, Vulcan or Duratec?
 

·
Registered
Joined
·
2,425 Posts
Well, if the EGR test does "nothing", that proves that either the EGR passages are clogged or the valve is not vorking and probably DFPE sensor is all right...

And yes, those codes don't seem to be related. Last code can be even an O2 sensor bad.
 

·
Registered
Joined
·
23,352 Posts
Replace dpfe sensor (egr backpressure sensor) with a borg-warner #egr155 from advance auto or oreilly and clear the codes with a scan tool or disconnect neg. batt. cable for a few mins. If o2 sensor code (po1131) returns later, replace the upstream o2 sensor bank 1 (firewall).
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #9 ·
Well, if the EGR test does "nothing", that proves that either the EGR passages are clogged or the valve is not vorking and probably DFPE sensor is all right...

And yes, those codes don't seem to be related. Last code can be even an O2 sensor bad.
I sucked on it and the RPM changed...the EGR valve is fine...so what's next?
 

·
Registered
Joined
·
2,425 Posts
Well, now that you know that valve is fine, next is what sheila said... for the P0401 code.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #11 ·
Nice I just bought a new B-W DPFE sensor from Ebay for $40...hopefully that solves this problem. I will update...thanks guys!
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #14 ·
MMM I drove the car again and the check engine lights came back on the p1131 code disappeared but the p0401 code is still present.
 
1 - 14 of 14 Posts
Top