Taurus Car Club of America : Ford Taurus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I started the car after lunch and it had a rough idle and the check engine light started blinking. It ran fine on the way to work, no hint of misfire. OBD returned P0306, misfire in cylinder 6. I replace the spark plug and switched ignition coils on cyliders 5 and 6. Cleared the codes and restarted. Still running rough. Check engine light starts blinking after about a minute. Check the code and still get a P0306. It doesn't appear to be the spark plug or ignition coil. There was a strong gasoline smell in the garage as soon as I started the engine so it appears to be getting fuel. Any suggestions?
 

·
Registered
Joined
·
131 Posts
There are fuel injector testers, to test for FI cycling, you might want to try that route? Hummm, I turn my '15 V6 N/A 3.5 Limited on, & I certainly don't smell gas. Is there a leak somewhere in the fuel line? Also how many miles on the vehicle? When were the plugs changed, if ever? I personally, have worked on vehicles that seemed to have spark at the plug , but it wasn't strong enough , & it misfired, even though it seemed to have adequate spark. & , as with injector testers , there are testers that test for adequate spark , too. Try the old switch technique , switch NO.6 plug & CP , for another plug & CP that's not sending a misfire code.
 

·
Registered
Joined
·
41 Posts
Stuck open injector perhaps? Any smoke from the tailpipe? Try using a stethoscope or long screwdriver to see if the #6 injectors is ticking like the others.
 
1 - 9 of 9 Posts
Top