Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter · #1 ·
2001 Taurus Vulcan Engine

my car did have a P0301 trouble code, but it wont seem to give a code anymore. The engine runs rough at about 800 and 1500 RPM and during acceleration and deacceleration. I checked the spark plug gaps, replace the spark plug wires, and the spark plugs were recently replaced. One thing I had considered is the ignition coil, but I don't know how to test them.

Any ideas?
 

·
Premium Member
Joined
·
474 Posts
Take the coil off and carefully inspect it top and bottom for hairline cracks.
 

·
Registered
Joined
·
142 Posts
Get ready to replace the coil. I guarantee that within 6 months you'll need to have it replaced, probably sooner.

Since you have the time, I forget if the #1 Coil is one of the easy ones to get to. If it is, you should buy yourself that part now and just do it...if not, you may want to consider getting all 6 and either paying someone to do all of them for you, or do them yourself.
 

·
Premium Member
Joined
·
474 Posts
Get ready to replace the coil. I guarantee that within 6 months you'll need to have it replaced, probably sooner.

Since you have the time, I forget if the #1 Coil is one of the easy ones to get to. If it is, you should buy yourself that part now and just do it...if not, you may want to consider getting all 6 and either paying someone to do all of them for you, or do them yourself.
The OP has a Vulcan. it has one coil pack. Not 6 COPs like the duratec.
 
1 - 4 of 4 Posts
Top