Taurus Car Club of America : Ford Taurus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2001 Taurus 3.0l "U" vin
I got an engine light a while back for a EGR System Malfunction (Don't remember what that code number was) and a P0301 code for misfire on cylinder 3. The engine was misfiring badly. After researching the codes - I changed out the EGR valve Switch (DPFE) and the EGR code went away. I changed Plugs & Wires and still had the 301 code. I did some more research and everyone said look at the coil for cracks - sure enough it was full of them and after changing the coil - the car ran perfectly - for three weeks. Now I have the P0301 code again - but on cylinder 1 this time. I checked the plugs again and they all look fine. I am at my wits end with this car. It took me three months to afford the coil/plugs/wires due to health issues in my family draining all of my money. This is our only vehicle and I need help diagnosing what is now wrong. Could the EGR valve cause this? Could clogged passages in the throttle body cause this? I need to try to fix this as cheaply as possible, but am willing to do any work necesary myself. Can anyone shed some light on this issue - or tell me how to test (and what I should test) to fgiure out what is still wrong? I appreciate any time any of you devote to my problem - and thank you all in advance.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Plugs all still look brand new.

They have about 500 miles on them since replaced.

There is no oil or carbon deposits on them.

Any other suggestions?
 
1 - 3 of 3 Posts
Top