Taurus Car Club of America : Ford Taurus Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
527 Posts
Discussion Starter · #1 ·
Guess my alternator has stopped regulating the charge voltage for the last time. Now to find out what else may have been affected when the alternator started to go. Turned the key to start, all dash lights alive and well but only a click and now the dash lights flash off and on with the clicking noise. Any ideas on what to check for when replacing the alternator? This is on an 05 Mercury Sable with the Duratec motor and 178k on the odometer. As far as I know the alternator has never been replaced and I have had the car since 2008.

And, yes I know that the job is going to be, shall I say fun considering where the thing is located on this motor,
 

·
Registered
Joined
·
11,585 Posts
Guess my alternator has stopped regulating the charge voltage for the last time. Now to find out what else may have been affected when the alternator started to go. Turned the key to start, all dash lights alive and well but only a click and now the dash lights flash off and on with the clicking noise. Any ideas on what to check for when replacing the alternator? This is on an 05 Mercury Sable with the Duratec motor and 178k on the odometer. As far as I know the alternator has never been replaced and I have had the car since 2008.

And, yes I know that the job is going to be, shall I say fun considering where the thing is located on this motor,
Your starting symptoms is more battery/battery cable. Overcharge will kill the battery.
Alt is a pain to do.
-chart-
 
1 - 2 of 2 Posts
Top