Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Please help, I cannot figure out why my heat wont work. I have a 2001 taurus ses, the heat warms up a little bit only if the car is sitting still, while driving it never warms at all like the cold air cools down the coolant in the radiator. I installed a new radiator a couple months ago, a heater core like two years ago, a thermostat a few months ago, and made sure the coolant was full. I checked the heater core hoses with a laser thermometer both sides were over 200° F. Blend doors appear to be working fine. I really dont know what else to do. Any help would be much appreciated
 

·
Registered
Joined
·
3,224 Posts
Always had heat problems with the Vulcan engine's, i always get toasty hot heat with the duratec engine's..
Well yeah, the Duratec is all aluminum. Iron block and heads + time = erosion. If you don't change the coolant it will catch up. Not that the Duratec is immune mind you, I've replaced the heater core in a 'Tec before.
 

·
Registered
Joined
·
6,606 Posts
If the heater core was replaced because of being plugged and a full block flush with removing freeze pulls like Ford has indicated in their procedure then it could be pulling again. The blocks have been known to a lot of casting sand that will pull heater cores. I found that the pluggage I got out was mostly non magnetic material.


You may want to try to do a reverse flush with compressed air to flush the core.
 

Attachments

1 - 5 of 5 Posts
Top