Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
OK..have no lights on the Bull..weird thing is when i turn the switch on the headlights will turn on, but NOTHING else works. Replaced the switch..not it, checked fuses under hood and dash..all good. ANYONE have an idea before i have to spend a buttload at Ford having it checked??
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
Also not sure if its related, but months ago the DRL quit working, like I said the lights will turn on but nothing else..I figgured its some sort of safety deal so you dont lose lights when crap goes wrong.
 

·
Registered
Joined
·
135 Posts
I would just do the obviuos checks like the ground from the neg battery
cable, the main groung on the firewall, under hood on pass side, and look for
water in the headlites and taillites.
it sounds like a bad DRL module, but more to it than that. don't go to
the dealer, i did and they charged me $250 to tell me i have a short, well
DUH, tell me something i don't know. just call around and find a good
mech who specializes in electr stuff, they're out there and much cheaper.
there is a thread about DRL's in the electronic section, perhaps read
that and it will give you some info.
dave
 

·
Premium Member
Joined
·
15,922 Posts
I've had that problem before, but it was due to my own stupidity. I forgot to make sure the headlight harness (that goes to the switch) was tight. I would suggest maybe the relay for the parking lights isn't working right if you're sure the harness is tight.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
where are the relays located at? And the DLR modual and how do you test it..and are there any other relays/fuses/connections to check?
 
1 - 5 of 5 Posts
Top