Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,377 Posts
Discussion Starter · #1 ·
I just replaced the starter and ground strap in my 96 crown vic. To do the rear ground strap i had to remove the heater core hose's. I reattached the hose's, filled the reservoir, started let it run watched the fluid go down, checked for leaks, all was good. Till i noticed the upper radiator hose was empty.
The fluid in the reservoir is holding steady, the car isnt over heating, the heat is kicking like an oven, the reservoir is holding pressure and not taking any more fluid even after 2 warm ups and cool downs.
Isn't this hose supposed to have fluid?
Engine has less then 10 thousand miles on it. complete rebuild with new thermostat, water pump, oil pump so on and so forth.
Oil is clean, cooling system holding pressure. no weird smells.
So long story short..... What is causing this?
 

·
Registered
Joined
·
10,574 Posts
I just replaced the starter and ground strap in my 96 crown vic. To do the rear ground strap i had to remove the heater core hose's. I reattached the hose's, filled the reservoir, started let it run watched the fluid go down, checked for leaks, all was good. Till i noticed the upper radiator hose was empty.
The fluid in the reservoir is holding steady, the car isnt over heating, the heat is kicking like an oven, the reservoir is holding pressure and not taking any more fluid even after 2 warm ups and cool downs.
Isn't this hose supposed to have fluid?
Engine has less then 10 thousand miles on it. complete rebuild with new thermostat, water pump, oil pump so on and so forth.
Oil is clean, cooling system holding pressure. no weird smells.
So long story short..... What is causing this?
Do not know details but there is likely an air bleed somewhere.

I have 4.6 in Lin Cont and it has a O-ring plug to let air out at a high point.

-chart-
 

·
Registered
Joined
·
3,377 Posts
Discussion Starter · #4 · (Edited)
no luck on bleeder. also notice the fan is on constantly. wondering if the fan is supposed to run constant on p71 engine. hmm. time to research.
 

·
Registered
Joined
·
3,377 Posts
Discussion Starter · #5 ·
relay is stuck and not switching off. swapped it with another and fan shuts off. maybe the thermostat will open and i can bleed out the air.
 
1 - 5 of 5 Posts
Top